Unable to login to iX Hello Employee

Incident Report for iXH EU Status

Resolved

Issue has been resolved now.
Posted Jul 03, 2026 - 13:35 UTC

Update

BRC was raised. Issue resolved
Posted Jul 03, 2026 - 12:59 UTC

Investigating

Users not able to login to ix Hello Employee EU instance
Posted Jul 03, 2026 - 12:58 UTC
This incident affected: ixHello Employee (Employee).